Back to overview
Resolved

Planned infrastructure maintenance across all domains and services

Apr 22, 2026 at 5:10am UTC  –  Apr 30, 2026 at 7:55pm UTC
Affected services
Website & Store

Resolved
Apr 30, 2026 at 7:55pm UTC

Maintenance ended

Created
Apr 22, 2026 at 5:10am UTC

We will be conducting planned infrastructure maintenance across all of our domains and services from April 22 through April 30.

This maintenance is part of a major foundational upgrade to strengthen the reliability, scalability, and long-term stability of our platform. During this maintenance window, some services may experience temporary interruptions, degraded performance, delayed responses, or limited availability.

These improvements affect our broader domain and infrastructure environment, and some parts of our main website may also be impacted during the process.

Our team is working carefully to minimize disruption and restore full service as quickly as possible. We will continue to share status updates as needed throughout the maintenance window.

If you need assistance during this time, please contact our support team.

Thank you for your patience and understanding.